Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This incident has been resolved. #smite
Posted 8 months ago. Jul 18, 2016 - 12:04 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 8 months ago. Jul 18, 2016 - 11:53 EDT