Paladins PC Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
The emergency restart of #Paladins #PC has been completed.
Posted about 1 month ago. Oct 07, 2017 - 01:45 EDT
Identified
We are performing an emergency restart of #Paladins #PC. The game will be back up shortly.
Posted about 1 month ago. Oct 07, 2017 - 01:28 EDT
This incident affected: Paladins PC.