Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 2 months ago. Jan 28, 2017 - 19:31 EDT
Monitoring
We have identified the issue and are monitoring the situation. #SMITE PC
Posted about 2 months ago. Jan 28, 2017 - 19:06 EDT
Update
We are currently looking into issues with Smite PC. #SMITE PC
Posted about 2 months ago. Jan 28, 2017 - 18:33 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted about 2 months ago. Jan 28, 2017 - 18:23 EDT
This incident affected: Smite PC - North America / Europe.