Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Issue with #Paladins PC has been resolved.
Posted 4 months ago. Jun 18, 2017 - 06:10 EDT
Monitoring
Emergency restart of #Paladins PC is complete and game is open; we are continuing to monitor.
Posted 4 months ago. Jun 18, 2017 - 05:47 EDT
Update
Performing an emergency restart of #Paladins PC; game back shortly.
Posted 4 months ago. Jun 18, 2017 - 04:59 EDT
Identified
We have identified an issue with #Paladins PC and are actively working to resolve.
Posted 4 months ago. Jun 18, 2017 - 04:53 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 4 months ago. Jun 18, 2017 - 04:14 EDT
This incident affected: Paladins PC.