Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Paladins incident has been resolved#paladins
Posted 6 months ago. Oct 04, 2016 - 14:05 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 6 months ago. Oct 04, 2016 - 13:52 EDT