Realm Royale PS4 Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This #RealmRoyale #PS4 emergency restart has been completed.
Posted 3 months ago. Jan 28, 2019 - 07:54 EST
Identified
We are performing an emergency restart for #RealmRoyale #PS4. Game will be back up shortly.
Posted 3 months ago. Jan 28, 2019 - 07:01 EST
This incident affected: Realm Royale (Realm Royale PS4).