Smite PC Oceania Servers are Currently Unavailable
Incident Report for Hi-Rez Studios, Inc
Resolved
Smite PC Oceania Servers are back online #smite
Posted almost 2 years ago. Jul 30, 2015 - 06:48 EDT
Investigating
Smite PC Oceania Servers are Currently Unavailable #smite
Posted almost 2 years ago. Jul 30, 2015 - 06:31 EDT