Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted over 1 year ago. Mar 04, 2016 - 15:47 EST
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted over 1 year ago. Mar 04, 2016 - 15:41 EST