Hirez Games possible issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Experienced brief datacenter connectivity issue. All products recovering normally with minimal impact.
Posted about 1 year ago. Mar 17, 2016 - 09:30 EDT
Investigating
Automated services have detected a possible problem our Atlanta servers and may affect all games. #SMITE #Tribes #Paladins. We are investigating.
Posted about 1 year ago. Mar 17, 2016 - 09:21 EDT