Paladins PC Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
Emergency restart has been resolved for #Paladins #PC
Posted 4 months ago. Jun 16, 2017 - 12:42 EDT
Monitoring
Emergency restart has been completed and we will continue to monitor #Paladins #PC
Posted 4 months ago. Jun 16, 2017 - 12:05 EDT
Investigating
We will be performing an emergency restart of #Paladins #PC
Posted 4 months ago. Jun 16, 2017 - 11:56 EDT
This incident affected: Paladins PC.