Problems with Matches on Paladins
Incident Report for Hi-Rez Studios, Inc
Resolved
We had to do an emergency restart to alleviate match making issues.
Sorry for the inconvenience.
Posted about 2 years ago. Dec 11, 2015 - 11:04 EST
Investigating
Paladins is having problems generating matches #Paladins
Posted about 2 years ago. Dec 11, 2015 - 10:42 EST