Tribes PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Logins have resumed to normal.
Posted over 1 year ago. Aug 04, 2016 - 15:05 EDT
Identified
We are aware of the login issues effecting Tribes Ascend at the moment, we are working to resolve this issue.
Apologies for the inconvenience.
Posted over 1 year ago. Aug 04, 2016 - 14:54 EDT
Investigating
Automated services have detected a possible problem with #Tribes PC. We are investigating.
Posted over 1 year ago. Aug 04, 2016 - 14:41 EDT