Connectivty
Incident Report for Hi-Rez Studios, Inc
Resolved
At this point connectivity has been restored for the effected users.
#Smite #Paladins
Posted 2 months ago. Jun 12, 2017 - 22:00 EDT
Investigating
We are aware of some of the issues our users are experiencing with connectivity.
We are working to restore services for these users and appreciate your patience.
#Smite #Paladins
Posted 2 months ago. Jun 12, 2017 - 21:35 EDT
This incident affected: Smite PC - North America / Europe, Smite Xbox - North America / Europe, and Paladins PC.