Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This incident has been resolved.#smite
Posted about 1 year ago. May 10, 2016 - 10:33 EDT
Investigating
Smite PC users will have trouble logging in, we are investigating# smite
Posted about 1 year ago. May 10, 2016 - 10:14 EDT
Identified
We have identified an issue with logins on smite PC and are working to alleviate this issue.
#SMITE
Posted about 1 year ago. May 10, 2016 - 10:13 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted about 1 year ago. May 10, 2016 - 10:11 EDT