Smite Blitz Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This #SmiteBlitz issue has been resolved.
Posted Feb 28, 2020 - 09:05 EST
Investigating
We are aware of an issue that is preventing some players from logging into their respective servers on Smite Blitz. Our investigation into this issue is still on-going. We apologize for the inconvenience, and we thank you for your patience as we continue to work through this issue.
Posted Feb 27, 2020 - 18:35 EST
This incident affected: SMITE Blitz (SMITE Blitz Mobile).