Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 10 months ago. Jan 18, 2017 - 11:42 EST
Identified
We are looking into issues with Paladins PC. #PALADINS
Posted 10 months ago. Jan 18, 2017 - 11:40 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 10 months ago. Jan 18, 2017 - 11:37 EST
This incident affected: Paladins PC.