Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
We have corrected an issue with #Smite #Xbox and are continuing to monitor.
Posted 3 months ago. Jun 08, 2017 - 23:33 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 3 months ago. Jun 08, 2017 - 23:12 EDT
This incident affected: Smite Xbox - North America / Europe.