Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PC incident has been resolved. #SmitePC
Posted 3 months ago. Feb 07, 2017 - 15:54 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 3 months ago. Feb 07, 2017 - 15:44 EST
This incident affected: Smite PC - North America / Europe.