Smite PC Match Making Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 4 months ago. Jul 07, 2018 - 15:38 EDT
Monitoring
The fix has been implemented and Logins have resumed!
Posted 4 months ago. Jul 07, 2018 - 15:14 EDT
Identified
We are pausing logins so we can implement a fix for the issue.
Posted 4 months ago. Jul 07, 2018 - 15:08 EDT
Investigating
We are looking into the issue affecting queues for Smite PC.
Posted 4 months ago. Jul 07, 2018 - 15:06 EDT
This incident affected: Smite (Smite PC).