Unplanned HotFix to SMITE PC - restarting in 20 minutes
Incident Report for Hi-Rez Studios, Inc
Resolved
HotFix has been applied. Game is back up. #SMITE
Posted about 2 years ago. Sep 25, 2015 - 16:43 EDT
Identified
Applying HotFix to correct problem with Steam Logins; Restarting Smite in 20 min #SMITE
Posted about 2 years ago. Sep 25, 2015 - 16:03 EDT