Smite XBox Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 2 months ago. Feb 01, 2017 - 09:14 EDT
Identified
We are currently aware of the issues affecting #Smite on #Xbox and we are working to resolve them.
Posted about 2 months ago. Feb 01, 2017 - 08:28 EDT
This incident affected: Smite Xbox - North America / Europe.