Hi-Rez PC Games Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Mar 22, 2018 - 04:26 EDT
Monitoring
PC Games are currently recovering, will continue to monitor.
Posted Mar 22, 2018 - 04:20 EDT
Investigating
We are currently investigating possible issues with Smite and Paladins PC.
Posted Mar 22, 2018 - 02:34 EDT
This incident affected: SMITE (SMITE PC) and Paladins (Paladins PC).