Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Paladins incident has been resolved.#paladins
Posted about 1 year ago. Oct 15, 2016 - 12:51 EDT
Update
Investigating: We are currently investigating this Paladins issue#paladins
Posted about 1 year ago. Oct 15, 2016 - 12:42 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted about 1 year ago. Oct 15, 2016 - 12:24 EDT