Smite Xbox and PS4 issue.
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 13 days ago. Nov 04, 2018 - 12:16 EST
Monitoring
A fix has been implemented and the games are back up.
Posted 13 days ago. Nov 04, 2018 - 10:15 EST
Investigating
We are investigating an issue with Smite PS4 and Xbox.
Posted 13 days ago. Nov 04, 2018 - 09:34 EST
This incident affected: Smite (Smite PS4, Smite Xbox).