Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved #Paladins #PC
Posted 8 months ago. Mar 05, 2017 - 17:14 EST
Update
We are continuing to work to resolve the issues involving match making in #Paladins #PC
We apologize for the inconvenience and appreciate your continued patience.
Posted 8 months ago. Mar 05, 2017 - 12:48 EST
Identified
We are working to resolve issues involving matches on #Paladins #PC
Posted 8 months ago. Mar 05, 2017 - 09:07 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 8 months ago. Mar 05, 2017 - 09:00 EST
This incident affected: Paladins PC.