Smite PS4 Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 4 months ago. Aug 08, 2018 - 02:20 EDT
Monitoring
#Smite #PS4 is back up. We are monitoring the results.
Posted 4 months ago. Aug 08, 2018 - 01:43 EDT
Investigating
We are performing an emergency restart for #Smite #PS4. Game will be back up soon.
Posted 4 months ago. Aug 08, 2018 - 01:28 EDT
This incident affected: Smite (Smite PS4).