We we be pausing logins for Paladins PC for a few moments
Incident Report for Hi-Rez Studios, Inc
Resolved
Logins for #Paladins #PC have been resumed
Posted 5 months ago. May 17, 2017 - 18:25 EDT
Investigating
We we be pausing logins for Paladins PC for a few moments #PaladinsPC
Posted 5 months ago. May 17, 2017 - 18:13 EDT
This incident affected: Paladins PC.