Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Brief data center connectivity issue caused minor drop of players; we have recovered.
Posted over 1 year ago. Mar 17, 2016 - 23:27 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted over 1 year ago. Mar 17, 2016 - 23:11 EDT