Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Restart of #Paladins PC has been completed.
Posted 23 days ago. Sep 29, 2017 - 07:19 EDT
Update
We are going to perform an emergency restart of #Paladins PC in a moment
Posted 23 days ago. Sep 29, 2017 - 07:06 EDT
Identified
We are limiting logins momentarily for #Paladins PC while we fix an issue.
Posted 23 days ago. Sep 29, 2017 - 06:42 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 23 days ago. Sep 29, 2017 - 06:39 EDT
This incident affected: Paladins PC.