Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Mar 14, 2018 - 14:01 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted Mar 14, 2018 - 13:46 EDT