Smite Xbox Matchmaking
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Jul 16, 2018 - 22:58 EDT
Monitoring
The issue with matchmaking on Smite Xbox has been addressed, and logins have resumed. We will continue to monitor.
Posted Jul 16, 2018 - 22:24 EDT
Identified
We are temporarily limiting logins for Smite Xbox to address the issue.
Posted Jul 16, 2018 - 22:20 EDT
Investigating
There is currently an issue that is affecting Matchmaking on Smite Xbox. We are investigating
Posted Jul 16, 2018 - 22:10 EDT
This incident affected: SMITE (SMITE Xbox).