Smite Crossplay/PS4 Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This #Smite #PC, #PS4, #Switch, & #Xbox emergency restart has been completed.
Posted 12 days ago. May 15, 2019 - 07:53 EDT
Identified
We are performing an emergency restart for #Smite #PC, #PS4, #Switch, & #Xbox. Game will be back up soon.
Posted 12 days ago. May 15, 2019 - 07:38 EDT
This incident affected: Smite (Smite PC, Smite PS4, Smite Xbox, Smite Switch).