Unable to Log in to Smite PC
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 2 years ago. Oct 12, 2015 - 13:24 EDT
Investigating
We are currently investigating this issue.
Posted about 2 years ago. Oct 12, 2015 - 13:10 EDT