Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This issues is now resolved .
Posted over 1 year ago. Feb 03, 2017 - 14:35 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted over 1 year ago. Feb 03, 2017 - 13:35 EST