Realm Royale Matchmaking
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 2 months ago. Jul 28, 2018 - 23:58 EDT
Monitoring
We have implemented a fix for the matchmaking issue. Logins have resumed. We will continue to monitor.
Posted about 2 months ago. Jul 28, 2018 - 23:28 EDT
Identified
We are working to fix an issue that is affecting matchmaking on Realm Royale. Players will be unable to login during this time.
Posted about 2 months ago. Jul 28, 2018 - 23:24 EDT
This incident affected: Realm Royale (Realm Royale PC).