Paladins Match Making Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
The Paladins Match Making issues we believe are resolved. #Paladins
Posted about 2 years ago. Dec 11, 2015 - 15:29 EST
Investigating
We are aware of the issues with match making and are investigating the problem.
Posted about 2 years ago. Dec 11, 2015 - 12:04 EST