Hirez Games possible issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This incident has been resolvedSMITE #Tribes #Paladins
Posted about 1 year ago. May 03, 2016 - 22:50 EDT
Update
Investigating: We are currently investigating this issue. SMITE #Tribes #Paladins
Posted about 1 year ago. May 03, 2016 - 22:47 EDT
Investigating
Automated services have detected a possible problem our Atlanta servers and may affect all games. #SMITE #Tribes #Paladins. We are investigating.
Posted about 1 year ago. May 03, 2016 - 22:41 EDT