Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Restart complete. The game is back up.
Posted 7 months ago. Feb 11, 2018 - 14:33 EST
Identified
We are performing an emergency restart on #Smite #Xbox.
Posted 7 months ago. Feb 11, 2018 - 14:20 EST
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 7 months ago. Feb 11, 2018 - 14:18 EST
This incident affected: Smite (Smite Xbox).