Tribes PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Tribes incident has been resolved.#tribes
Posted 9 months ago. Sep 25, 2016 - 10:05 EDT
Investigating
Automated services have detected a possible problem with #Tribes PC. We are investigating.
Posted 9 months ago. Sep 25, 2016 - 07:16 EDT