Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 2 months ago. Jun 12, 2017 - 18:50 EDT
Identified
We are currently aware of the connectivity issues effecting #Paladins #PC and are working to restore services for those users.
Posted 2 months ago. Jun 12, 2017 - 17:47 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 2 months ago. Jun 12, 2017 - 17:42 EDT
This incident affected: Paladins PC.