Realm Royale XBox Patch Maintenance
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 16 days ago. Feb 07, 2019 - 20:10 EST
Update
We are still working on an issue affecting Realm Royale on XBox.
Posted 16 days ago. Feb 07, 2019 - 16:59 EST
Identified
Realm Royale for #XBox is currently under patch maintenance
Posted 16 days ago. Feb 07, 2019 - 14:24 EST
This incident affected: Realm Royale (Realm Royale PC, Realm Royale Xbox).