Possible server issues for PC and XBOX
Incident Report for Hi-Rez Studios, Inc
Resolved
The servers are back to 100%. The issue was related to a DDOS attack
Posted over 2 years ago. Jul 24, 2015 - 18:42 EDT
Investigating
We are investigating
Posted over 2 years ago. Jul 24, 2015 - 18:26 EDT