XBox Login Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Logins issues have been resolved for those logging in on Xbox.
Posted 3 months ago. May 30, 2019 - 06:55 EDT
Update
We are still investigating these issues.
Posted 3 months ago. May 30, 2019 - 01:36 EDT
Investigating
We are investigating an issue that is preventing players from being able to log in on XBox. You can try restarting your XBox as that appears to help. Thank you for your patience and we apologize for any inconvenience that this may have caused.
Posted 3 months ago. May 29, 2019 - 20:40 EDT
This incident affected: Smite (Smite Xbox), Realm Royale (Realm Royale Xbox), and Paladins (Paladins Xbox).