Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 month ago. Apr 18, 2017 - 15:19 EDT
Monitoring
We are currently monitoring the situation. Thank you for your patience.
Posted about 1 month ago. Apr 18, 2017 - 15:11 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted about 1 month ago. Apr 18, 2017 - 15:07 EDT