Smite XBOX 2.15 hot-fix
Incident Report for Hi-Rez Studios, Inc
Resolved
The Hot-fix for SMITE on XBOX has been completed.
Posted almost 2 years ago. Oct 26, 2015 - 13:01 EDT
Investigating
We will be implementing a hot-fix for smite at 1PM EDT (7PM CEST).
Limited access will being at 12:30 PM EDT
#SMITE
Posted almost 2 years ago. Oct 26, 2015 - 11:12 EDT