Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#SMITE PC issue has been resolved; environment stable.
Posted 2 months ago. Jan 11, 2017 - 08:58 EDT
Monitoring
#SMITE PC restarted; logins re-enabled; we are continuing to monitor situation
Posted 2 months ago. Jan 11, 2017 - 08:24 EDT
Identified
#SMITE PC will be performing an emergency restart; game back shortly.
Posted 2 months ago. Jan 11, 2017 - 07:49 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 2 months ago. Jan 11, 2017 - 07:36 EDT
This incident affected: Smite PC - North America / Europe.