Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#Paladins #PC Has returned to normal.
Posted Aug 13, 2017 - 19:29 EDT
Monitoring
We are currently monitoring #Paladins #Pc
Posted Aug 13, 2017 - 18:01 EDT
Update
We are currently investigating the issue with #Paladins #PC
Posted Aug 13, 2017 - 17:46 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted Aug 13, 2017 - 17:38 EDT
This incident affected: Paladins (Paladins PC).