Smite Tactics Patch at 5:15pm EST
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Tactics incident has been resolved. #Tactics
Posted 3 months ago. Apr 19, 2017 - 20:16 EDT
Investigating
We will be Deploying a fix to Tactics at 5:15pm EST. #Tactics
Posted 3 months ago. Apr 19, 2017 - 17:11 EDT
This incident affected: Smite Tactics.