Realm Royale Post-Patch Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 month ago. Oct 18, 2018 - 01:00 EDT
Update
We are working to bring the game back online as soon as possible. We will continue to update the issue as needed.
Posted about 1 month ago. Oct 17, 2018 - 23:27 EDT
Update
We are still working to address the issue with Realm Royale. We will continue to update progress as needed.
Posted about 1 month ago. Oct 17, 2018 - 21:45 EDT
Identified
Realm Royale is down temporarily to address an issue with match queues. The game will be back up as soon as possible.
Posted about 1 month ago. Oct 17, 2018 - 17:46 EDT
This incident affected: Realm Royale (Realm Royale PC).