Smite Crossplay and PS4 Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
The emergency restart has been completed.
Posted 4 months ago. Jun 28, 2019 - 04:44 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. Jun 28, 2019 - 04:42 EDT
Investigating
We are performing an emergency restart on #Smite #Crossplay and #PS4
Posted 4 months ago. Jun 28, 2019 - 04:24 EDT
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch).